<!DOCTYPE html><html class="html" lang="en-US"><head><meta charset="UTF-8"/>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>!function(){function e(i){return e="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e(i)}__ez.pel=function(){var i=[];function t(t,o,_,d,n,r,a,s){if(__ez.dot.isDefined(t)&&0!=__ez.dot.isAnyDefined(t.getSlotElementId,t.ElementId)){void 0===s&&(s=!1);var p=parseInt(__ez.dot.getTargeting(t,"ap")),f=__ez.dot.getSlotIID(t),u=__ez.dot.getAdUnit(t,s),g=parseInt(__ez.dot.getTargeting(t,"compid")),c=0,l=0,z=function(i){if("undefined"==typeof _ezim_d)return!1;var t=__ez.dot.getAdUnitPath(i).split("/").pop();if("object"===("undefined"==typeof _ezim_d?"undefined":e(_ezim_d))&&_ezim_d.hasOwnProperty(t))return _ezim_d[t];for(var o in _ezim_d)if(o.split("/").pop()===t)return _ezim_d[o];return!1}(t);"object"==e(z)&&(void 0!==z.creative_id&&(l=z.creative_id),void 0!==z.line_item_id&&(c=z.line_item_id)),__ez.dot.isDefined(f,u)&&__ez.dot.isValid(o)&&("0"===f&&!0!==s||""===u||i.push({type:"impression",impression_id:f,domain_id:__ez.dot.getDID(),unit:u,t_epoch:__ez.dot.getEpoch(0),revenue:_,est_revenue:d,ad_position:p,ad_size:"",bid_floor_filled:n,bid_floor_prev:r,stat_source_id:a,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:g,line_item_id:c,creative_id:l,data:__ez.dot.dataToStr(o),is_orig:s||__ez.template.isOrig}))}}function o(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(i)&&i.length>0&&[i.filter((function(e){return e.is_orig})),i.filter((function(e){return!e.is_orig}))].forEach((function(e){for(;e.length>0;){var i=e[0].is_orig||!1,t=5;t>e.length&&(t=e.length);var o=e.splice(0,t),_=__ez.dot.getURL("/porpoiseant/army.gif")+"?orig="+(!0===i?1:0)+"&sts="+btoa(JSON.stringify(o));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(_+="&visit_uuid="+_ezaq.visit_uuid),__ez.dot.Fire(_)}})),i=[])}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),o()},AddAndFireOrig:function(e,i){t(e,i,0,0,0,0,0,!0),o()},AddById:function(e,t,o,_){var d=e.split("/");if(__ez.dot.isDefined(e)&&3===d.length&&__ez.dot.isValid(t)){var n=d[0],r={type:"impression",impression_id:d[2],domain_id:__ez.dot.getDID(),unit:n,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(t),is_orig:o||__ez.template.isOrig};void 0!==_&&(r.revenue=_),i.push(r)}},Fire:o,GetPixels:function(){return i}}}()}();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-0&cb=6', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-0&cb=5', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-0&cb=7', false, [], true, false, true, false);</script>
	
	<link rel="profile" href="https://gmpg.org/xfn/11"/>

	<meta name="robots" content="index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1"/>
<meta name="viewport" content="width=device-width, initial-scale=1"/>
	<!-- This site is optimized with the Yoast SEO plugin v19.6.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Arch2appimage: Convert Arch Package into Appimage using Python Script on Linux - TREND OCEANS</title>
	<meta name="description" content="Arch2appimage is a free and open-source script, or you can say, tool written in Python with the goal in mind to convert Arch Linux packages either from the official Arch Linux Repositories or from the AUR."/>
	<link rel="canonical" href="https://trendoceans.com/arch2appimage/"/>
	<meta property="og:locale" content="en_US"/>
	<meta property="og:type" content="article"/>
	<meta property="og:title" content="Arch2appimage: Convert Arch Package into Appimage using Python Script on Linux - TREND OCEANS"/>
	<meta property="og:description" content="Arch2appimage is a free and open-source script, or you can say, tool written in Python with the goal in mind to convert Arch Linux packages either from the official Arch Linux Repositories or from the AUR."/>
	<meta property="og:url" content="https://trendoceans.com/arch2appimage/"/>
	<meta property="og:site_name" content="TREND OCEANS"/>
	<meta property="article:publisher" content="https://www.facebook.com/trendoceans/"/>
	<meta property="article:published_time" content="2022-09-05T05:30:00+00:00"/>
	<meta property="article:modified_time" content="2022-09-04T09:32:32+00:00"/>
	<meta property="og:image" content="https://trendoceans.com/wp-content/uploads/2022/09/Arch2appimage.webp"/>
	<meta property="og:image:width" content="1280"/>
	<meta property="og:image:height" content="719"/>
	<meta property="og:image:type" content="image/webp"/>
	<meta name="author" content="Jake Redfield"/>
	<meta name="twitter:card" content="summary_large_image"/>
	<meta name="twitter:creator" content="@heythisisvivek"/>
	<meta name="twitter:site" content="@heythisisvivek"/>
	<meta name="twitter:label1" content="Written by"/>
	<meta name="twitter:data1" content="Jake Redfield"/>
	<meta name="twitter:label2" content="Est. reading time"/>
	<meta name="twitter:data2" content="7 minutes"/>
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Article","@id":"https://trendoceans.com/arch2appimage/#article","isPartOf":{"@id":"https://trendoceans.com/arch2appimage/"},"author":{"name":"Jake Redfield","@id":"https://trendoceans.com/#/schema/person/6b8e9e1777429be32b6d3aca64baaa90"},"headline":"Arch2appimage: Convert Arch Package into Appimage using Python Script on Linux","datePublished":"2022-09-05T05:30:00+00:00","dateModified":"2022-09-04T09:32:32+00:00","mainEntityOfPage":{"@id":"https://trendoceans.com/arch2appimage/"},"wordCount":954,"commentCount":0,"publisher":{"@id":"https://trendoceans.com/#organization"},"image":{"@id":"https://trendoceans.com/arch2appimage/#primaryimage"},"thumbnailUrl":"https://trendoceans.com/wp-content/uploads/2022/09/Arch2appimage.webp","keywords":["arch2appimage","convert arch program into appimage"],"articleSection":["FOSS","Linux","Tools","Topic"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://trendoceans.com/arch2appimage/#respond"]}]},{"@type":"WebPage","@id":"https://trendoceans.com/arch2appimage/","url":"https://trendoceans.com/arch2appimage/","name":"Arch2appimage: Convert Arch Package into Appimage using Python Script on Linux - TREND OCEANS","isPartOf":{"@id":"https://trendoceans.com/#website"},"primaryImageOfPage":{"@id":"https://trendoceans.com/arch2appimage/#primaryimage"},"image":{"@id":"https://trendoceans.com/arch2appimage/#primaryimage"},"thumbnailUrl":"https://trendoceans.com/wp-content/uploads/2022/09/Arch2appimage.webp","datePublished":"2022-09-05T05:30:00+00:00","dateModified":"2022-09-04T09:32:32+00:00","description":"Arch2appimage is a free and open-source script, or you can say, tool written in Python with the goal in mind to convert Arch Linux packages either from the official Arch Linux Repositories or from the AUR.","breadcrumb":{"@id":"https://trendoceans.com/arch2appimage/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://trendoceans.com/arch2appimage/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://trendoceans.com/arch2appimage/#primaryimage","url":"https://trendoceans.com/wp-content/uploads/2022/09/Arch2appimage.webp","contentUrl":"https://trendoceans.com/wp-content/uploads/2022/09/Arch2appimage.webp","width":1280,"height":719,"caption":"Arch2appimage"},{"@type":"BreadcrumbList","@id":"https://trendoceans.com/arch2appimage/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://trendoceans.com/"},{"@type":"ListItem","position":2,"name":"Blog","item":"https://trendoceans.com/blog/"},{"@type":"ListItem","position":3,"name":"Arch2appimage: Convert Arch Package into Appimage using Python Script on Linux"}]},{"@type":"WebSite","@id":"https://trendoceans.com/#website","url":"https://trendoceans.com/","name":"TREND OCEANS","description":"Tech place for geeks","publisher":{"@id":"https://trendoceans.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://trendoceans.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Organization","@id":"https://trendoceans.com/#organization","name":"TrendOceans","url":"https://trendoceans.com/","sameAs":["https://instagram.com/heythisisvivek","https://www.youtube.com/channel/UClRBOuS5x9PT8D6BpYaWO-A/videos","https://www.facebook.com/trendoceans/","https://twitter.com/heythisisvivek"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://trendoceans.com/#/schema/logo/image/","url":"https://trendoceans.com/wp-content/uploads/2020/08/TrendOceans.png","contentUrl":"https://trendoceans.com/wp-content/uploads/2020/08/TrendOceans.png","width":256,"height":256,"caption":"TrendOceans"},"image":{"@id":"https://trendoceans.com/#/schema/logo/image/"}},{"@type":"Person","@id":"https://trendoceans.com/#/schema/person/6b8e9e1777429be32b6d3aca64baaa90","name":"Jake Redfield","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://trendoceans.com/#/schema/person/image/","url":"https://trendoceans.com/wp-content/litespeed/avatar/fed8828c04da9a99e35032d8252e5c8b.jpg?ver=1662702048","contentUrl":"https://trendoceans.com/wp-content/litespeed/avatar/fed8828c04da9a99e35032d8252e5c8b.jpg?ver=1662702048","caption":"Jake Redfield"},"description":"Innovative tech mind with 12 years of experience working as a computer programmer, web developer, and security researcher. Capable of working with a variety of technology and software solutions, and managing databases.","sameAs":["https://trendoceans.com"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel="dns-prefetch" href="//s.w.org"/>
<link rel="dns-prefetch" href="//pagead2.googlesyndication.com"/>
<link rel="dns-prefetch" href="//www.googletagmanager.com"/>
<link rel="stylesheet" id="wp-block-library-css" href="https://trendoceans.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0.2" media="all"/>
<style id="wp-block-library-theme-inline-css">
.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code{border:1px solid #ccc;border-radius:4px;font-family:Menlo,Consolas,monaco,monospace;padding:.8em 1em}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large,.wp-block-quote.is-style-plain{border:none}.wp-block-search .wp-block-search__label{font-weight:700}:where(.wp-block-group.has-background){padding:1.25em 2.375em}.wp-block-separator.has-css-opacity{opacity:.4}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto}.wp-block-separator.has-alpha-channel-opacity{opacity:1}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}
</style>
<link rel="stylesheet" id="convertkit-broadcasts-css" href="https://trendoceans.com/wp-content/plugins/convertkit/resources/frontend/css/broadcasts.css?ver=1.9.8.4" media="all"/>
<style id="global-styles-inline-css">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</style>
<link rel="stylesheet" id="contact-form-7-css" href="https://trendoceans.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.6.3" media="all"/>
<link rel="stylesheet" id="ez-icomoon-css" href="https://trendoceans.com/wp-content/plugins/easy-table-of-contents/vendor/icomoon/style.min.css?ver=2.0.33.2" media="all"/>
<link rel="stylesheet" id="ez-toc-css" href="https://trendoceans.com/wp-content/plugins/easy-table-of-contents/assets/css/screen.min.css?ver=2.0.33.2" media="all"/>
<style id="ez-toc-inline-css">
div#ez-toc-container p.ez-toc-title {font-size: 120%;}div#ez-toc-container p.ez-toc-title {font-weight: 500;}div#ez-toc-container ul li {font-size: 95%;}div#ez-toc-container nav ul ul li ul li {font-size: %!important;}
.ez-toc-container-direction {
    direction: ltr;
}

.ez-toc-counter ul {
    counter-reset: item;
}



.ez-toc-counter nav ul li a::before {
    content: counters(item, ".", decimal) ". ";
    display: inline-block;
    counter-increment: item;
    margin-right: .2em; 

    float: left;
}


.ez-toc-widget-direction {
    direction: ltr;
}

.ez-toc-widget-container ul {
    counter-reset: item;
}



.ez-toc-widget-container nav ul li a::before {
    content: counters(item, ".", decimal) ". ";
    display: inline-block;
    counter-increment: item;
    margin-right: .2em; 

    float: left;
}


</style>
<link rel="stylesheet" id="oceanwp-style-css" href="https://trendoceans.com/wp-content/themes/oceanwp/assets/css/style.min.css?ver=1.0" media="all"/>
<link rel="stylesheet" id="child-style-css" href="https://trendoceans.com/wp-content/themes/oceanwp-child-theme-master/style.css?ver=6.0.2" media="all"/>
<link rel="stylesheet" id="simple-line-icons-css" href="https://trendoceans.com/wp-content/themes/oceanwp/assets/css/third/simple-line-icons.min.css?ver=2.4.0" media="all"/>
<link rel="stylesheet" id="wp-featherlight-css" href="https://trendoceans.com/wp-content/plugins/wp-featherlight/css/wp-featherlight.min.css?ver=1.3.4" media="all"/>
<link rel="stylesheet" id="oe-widgets-style-css" href="https://trendoceans.com/wp-content/plugins/ocean-extra/assets/css/widgets.css?ver=6.0.2" media="all"/>
<link rel="stylesheet" id="oss-social-share-style-css" href="https://trendoceans.com/wp-content/plugins/ocean-social-sharing/assets/css/style.min.css?ver=6.0.2" media="all"/>
<script src="https://trendoceans.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0" id="jquery-core-js"></script>
<script src="https://trendoceans.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2" id="jquery-migrate-js"></script>
<link rel="https://api.w.org/" href="https://trendoceans.com/wp-json/"/><link rel="alternate" type="application/json" href="https://trendoceans.com/wp-json/wp/v2/posts/27982"/><link rel="alternate" type="application/json+oembed" href="https://trendoceans.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftrendoceans.com%2Farch2appimage%2F"/>
<link rel="alternate" type="text/xml+oembed" href="https://trendoceans.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftrendoceans.com%2Farch2appimage%2F&amp;format=xml"/>
<meta name="generator" content="Site Kit by Google 1.82.0"/>
<!-- Google AdSense snippet added by Site Kit -->
<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236"/>
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com"/>
<!-- End Google AdSense snippet added by Site Kit -->

<!-- Google AdSense snippet added by Site Kit -->
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-8292788843997175" crossorigin="anonymous"></script>

<!-- End Google AdSense snippet added by Site Kit -->

<!-- Google Tag Manager snippet added by Site Kit -->
<script>
			( function( w, d, s, l, i ) {
				w[l] = w[l] || [];
				w[l].push( {'gtm.start': new Date().getTime(), event: 'gtm.js'} );
				var f = d.getElementsByTagName( s )[0],
					j = d.createElement( s ), dl = l != 'dataLayer' ? '&l=' + l : '';
				j.async = true;
				j.src = 'https://www.googletagmanager.com/gtm.js?id=' + i + dl;
				f.parentNode.insertBefore( j, f );
			} )( window, document, 'script', 'dataLayer', 'GTM-MRWVL7Z' );
			
</script>

<!-- End Google Tag Manager snippet added by Site Kit -->
<style type="text/css">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</style><link rel="icon" href="https://trendoceans.com/wp-content/uploads/2021/12/cropped-Site-Icon-32x32.png" sizes="32x32"/>
<link rel="icon" href="https://trendoceans.com/wp-content/uploads/2021/12/cropped-Site-Icon-192x192.png" sizes="192x192"/>
<link rel="apple-touch-icon" href="https://trendoceans.com/wp-content/uploads/2021/12/cropped-Site-Icon-180x180.png"/>
<meta name="msapplication-TileImage" content="https://trendoceans.com/wp-content/uploads/2021/12/cropped-Site-Icon-270x270.png"/>
		<style id="wp-custom-css">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</style>
		<!-- OceanWP CSS -->
<style type="text/css">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</style><script type="text/javascript">var ezouid = "1";</script><base href="https://trendoceans.com/arch2appimage/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 314194;
var ezdomain = 'trendoceans.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":314194,"domain_test_group":20230801,"engaged_time_visit":0,"ezcache_level":0,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"2064984f-4bde-4688-7b27-c33321808ced","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":150076,"response_time_orig":221,"serverid":"18.207.243.58:6980","state":"VA","t_epoch":1662761598,"template_id":126,"time_on_site_visit":0,"url":"https://trendoceans.com/arch2appimage/","user_id":0,"weather_precipitation":0,"weather_summary":"","weather_temperature":0,"word_count":1842,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_314194=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["2064984f-4bde-4688-7b27-c33321808ced", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>

<body class="post-template-default single single-post postid-27982 single-format-standard wp-embed-responsive wp-featherlight-captions oceanwp-theme dropdown-mobile default-breakpoint has-sidebar content-right-sidebar post-in-category-foss post-in-category-linux post-in-category-tools post-in-category-topic has-topbar has-breadcrumbs has-blog-grid no-lightbox elementor-default elementor-kit-10" itemscope="itemscope" itemtype="https://schema.org/Article">

			<!-- Google Tag Manager (noscript) snippet added by Site Kit -->
		<noscript>
			<iframe data-lazyloaded="1" src="about:blank" data-src="https://www.googletagmanager.com/ns.html?id=GTM-MRWVL7Z" height="0" width="0" style="display:none;visibility:hidden"></iframe><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MRWVL7Z" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
		
		<!-- End Google Tag Manager (noscript) snippet added by Site Kit -->
		<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></feColorMatrix><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0.49803921568627"></feFuncR><feFuncG type="table" tableValues="0 0.49803921568627"></feFuncG><feFuncB type="table" tableValues="0 0.49803921568627"></feFuncB><feFuncA type="table" tableValues="1 1"></feFuncA></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"></feComposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></feColorMatrix><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1"></feFuncR><feFuncG type="table" tableValues="0 1"></feFuncG><feFuncB type="table" tableValues="0 1"></feFuncB><feFuncA type="table" tableValues="1 1"></feFuncA></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"></feComposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></feColorMatrix><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765"></feFuncR><feFuncG type="table" tableValues="0 1"></feFuncG><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431"></feFuncB><feFuncA type="table" tableValues="1 1"></feFuncA></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"></feComposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></feColorMatrix><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1"></feFuncR><feFuncG type="table" tableValues="0 0.27843137254902"></feFuncG><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902"></feFuncB><feFuncA type="table" tableValues="1 1"></feFuncA></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"></feComposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></feColorMatrix><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0"></feFuncR><feFuncG type="table" tableValues="0 0.64705882352941"></feFuncG><feFuncB type="table" tableValues="0 1"></feFuncB><feFuncA type="table" tableValues="1 1"></feFuncA></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"></feComposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></feColorMatrix><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.78039215686275 1"></feFuncR><feFuncG type="table" tableValues="0 0.94901960784314"></feFuncG><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412"></feFuncB><feFuncA type="table" tableValues="1 1"></feFuncA></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"></feComposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></feColorMatrix><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745"></feFuncR><feFuncG type="table" tableValues="0 1"></feFuncG><feFuncB type="table" tableValues="0.44705882352941 0.4"></feFuncB><feFuncA type="table" tableValues="1 1"></feFuncA></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"></feComposite></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 "></feColorMatrix><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.098039215686275 1"></feFuncR><feFuncG type="table" tableValues="0 0.66274509803922"></feFuncG><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725"></feFuncB><feFuncA type="table" tableValues="1 1"></feFuncA></feComponentTransfer><feComposite in2="SourceGraphic" operator="in"></feComposite></filter></defs></svg>
	
	<div id="outer-wrap" class="site clr">

		<a class="skip-link screen-reader-text" href="#main">Skip to content</a>

		
		<div id="wrap" class="clr">

			

<div id="top-bar-wrap" class="clr hide-mobile">

	<div id="top-bar" class="clr container has-no-content">

		
		<div id="top-bar-inner" class="clr">

			
	<div id="top-bar-content" class="clr top-bar-left">

		
<div id="top-bar-nav" class="navigation clr">

	<ul id="menu-social" class="top-bar-menu dropdown-menu sf-menu"><li id="menu-item-72" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72"><a href="https://www.facebook.com/trendoceans" class="menu-link">Facebook</a></li><li id="menu-item-73" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-73"><a href="https://www.instagram.com/trendoceans/" class="menu-link">Instagram</a></li><li id="menu-item-74" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-74"><a href="https://twitter.com/trendoceans" class="menu-link">Twitter</a></li><li id="menu-item-2739" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2739"><a href="https://t.me/trendoceans" class="menu-link">Telegram</a></li><li id="menu-item-1667" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1667"><a href="https://www.youtube.com/channel/UClRBOuS5x9PT8D6BpYaWO-A" class="menu-link">Youtube</a></li><li id="menu-item-94" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-94"><a href="/cdn-cgi/l/email-protection#15767a7b61747661556167707b717a7670747b663b767a78" class="menu-link">E-mail</a></li></ul>
</div>

		
			
	</div><!-- #top-bar-content -->


		</div><!-- #top-bar-inner -->

		
	</div><!-- #top-bar -->

</div><!-- #top-bar-wrap -->


			
<header id="site-header" class="minimal-header effect-four clr" data-height="74" itemscope="itemscope" itemtype="https://schema.org/WPHeader" role="banner">

	
					
			<div id="site-header-inner" class="clr container">

				
				

<div id="site-logo" class="clr" itemscope="" itemtype="https://schema.org/Brand">

	
	<div id="site-logo-inner" class="clr">

						<a href="https://trendoceans.com/" rel="home" class="site-title site-logo-text">TREND OCEANS</a>
				
	</div><!-- #site-logo-inner -->

	
	
</div><!-- #site-logo -->

			<div id="site-navigation-wrap" class="clr">
			
			
			
			<nav id="site-navigation" class="navigation main-navigation clr" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement" role="navigation">

				<ul id="menu-top-menu" class="main-menu dropdown-menu sf-menu"><li id="menu-item-49" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-49"><a href="https://trendoceans.com/" class="menu-link"><span class="text-wrap">Home</span></a></li><li id="menu-item-50" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-50"><a href="https://trendoceans.com/blog/" class="menu-link"><span class="text-wrap">Blog</span></a></li><li id="menu-item-161" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children dropdown menu-item-161 nav-no-click"><a href="https://trendoceans.com/category/topic/" class="menu-link"><span class="text-wrap">Topic<i class="nav-arrow fa fa-angle-down" aria-hidden="true" role="img"></i></span></a>
<ul class="sub-menu">
	<li id="menu-item-166" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-166"><a href="https://trendoceans.com/category/topic/news/" class="menu-link"><span class="text-wrap">News</span></a></li>	<li id="menu-item-164" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-164"><a href="https://trendoceans.com/category/topic/foss/" class="menu-link"><span class="text-wrap">FOSS</span></a></li>	<li id="menu-item-165" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-165"><a href="https://trendoceans.com/category/topic/linux/" class="menu-link"><span class="text-wrap">Linux</span></a></li>	<li id="menu-item-168" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-168"><a href="https://trendoceans.com/category/topic/tools/" class="menu-link"><span class="text-wrap">Tools</span></a></li>	<li id="menu-item-15032" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15032"><a href="https://trendoceans.com/category/topic/android/" class="menu-link"><span class="text-wrap">Android</span></a></li>	<li id="menu-item-1439" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1439"><a href="https://trendoceans.com/category/topic/troubleshoot/" class="menu-link"><span class="text-wrap">Troubleshoot</span></a></li>	<li id="menu-item-167" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-167"><a href="https://trendoceans.com/category/topic/programming/" class="menu-link"><span class="text-wrap">Programming</span></a></li>	<li id="menu-item-169" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169"><a href="https://trendoceans.com/category/topic/web-development/" class="menu-link"><span class="text-wrap">Web Development</span></a></li>	<li id="menu-item-2708" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2708"><a href="https://trendoceans.com/category/topic/linux-distributions/" class="menu-link"><span class="text-wrap">Linux distributions</span></a></li></ul>
</li><li id="menu-item-186" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-186"><a href="https://trendoceans.com/privacy-policy/" class="menu-link"><span class="text-wrap">Privacy Policy</span></a></li><li id="menu-item-51" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51"><a href="https://trendoceans.com/contact/" class="menu-link"><span class="text-wrap">Contact</span></a></li><li id="menu-item-52" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52"><a href="https://trendoceans.com/about/" class="menu-link"><span class="text-wrap">About</span></a></li></ul>
			</nav><!-- #site-navigation -->

			
			
					</div><!-- #site-navigation-wrap -->
			
		
	
				
	
	<div class="oceanwp-mobile-menu-icon clr mobile-right">

		
		
		
		<a href="#" class="mobile-menu" aria-label="Mobile Menu">
							<i class="fa fa-bars" aria-hidden="true"></i>
								<span class="oceanwp-text">Menu</span>
				<span class="oceanwp-close-text">Close</span>
						</a>

		
		
		
	</div><!-- #oceanwp-mobile-menu-navbar -->

	

			</div><!-- #site-header-inner -->

			
<div id="mobile-dropdown" class="clr">

	<nav class="clr" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">

		<ul id="menu-top-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-49"><a href="https://trendoceans.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-50"><a href="https://trendoceans.com/blog/">Blog</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-161"><a href="https://trendoceans.com/category/topic/">Topic</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-166"><a href="https://trendoceans.com/category/topic/news/">News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-164"><a href="https://trendoceans.com/category/topic/foss/">FOSS</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-165"><a href="https://trendoceans.com/category/topic/linux/">Linux</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-168"><a href="https://trendoceans.com/category/topic/tools/">Tools</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15032"><a href="https://trendoceans.com/category/topic/android/">Android</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1439"><a href="https://trendoceans.com/category/topic/troubleshoot/">Troubleshoot</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-167"><a href="https://trendoceans.com/category/topic/programming/">Programming</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169"><a href="https://trendoceans.com/category/topic/web-development/">Web Development</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2708"><a href="https://trendoceans.com/category/topic/linux-distributions/">Linux distributions</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-186"><a href="https://trendoceans.com/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51"><a href="https://trendoceans.com/contact/">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52"><a href="https://trendoceans.com/about/">About</a></li>
</ul><ul id="menu-social-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72"><a href="https://www.facebook.com/trendoceans">Facebook</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-73"><a href="https://www.instagram.com/trendoceans/">Instagram</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-74"><a href="https://twitter.com/trendoceans">Twitter</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2739"><a href="https://t.me/trendoceans">Telegram</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1667"><a href="https://www.youtube.com/channel/UClRBOuS5x9PT8D6BpYaWO-A">Youtube</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-94"><a href="/cdn-cgi/l/email-protection#1c7f7372687d7f685c686e797278737f797d726f327f7371">E-mail</a></li>
</ul>
<div id="mobile-menu-search" class="clr">
	<form aria-label="Search this website" method="get" action="https://trendoceans.com/" class="mobile-searchform">
		<input aria-label="Insert search query" value="" class="field" id="ocean-mobile-search-1" type="search" name="s" autocomplete="off" placeholder="Search"/>
		<button aria-label="Submit search" type="submit" class="searchform-submit">
			<i class=" icon-magnifier" aria-hidden="true" role="img"></i>		</button>
					</form>
</div><!-- .mobile-menu-search -->

	</nav>

</div>

			
			
		
		
</header><!-- #site-header -->


			
			<main id="main" class="site-main clr" role="main">

				

<header class="page-header">

	
	<div class="container clr page-header-inner">

		
			<h1 class="page-header-title clr" itemprop="headline">Blog</h1>

			
		
		<nav aria-label="Breadcrumbs" class="site-breadcrumbs clr position-" itemprop="breadcrumb"><ol class="trail-items" itemscope="" itemtype="http://schema.org/BreadcrumbList"><meta name="numberOfItems" content="3"/><meta name="itemListOrder" content="Ascending"/><li class="trail-item trail-begin" itemprop="itemListElement" itemscope="" itemtype="https://schema.org/ListItem"><a href="https://trendoceans.com" rel="home" aria-label="Home" itemtype="https://schema.org/Thing" itemprop="item"><span itemprop="name"><i class=" icon-home" aria-hidden="true" role="img"></i><span class="breadcrumb-home has-icon">Home</span></span></a><span class="breadcrumb-sep">&gt;</span><meta content="1" itemprop="position"/></li><li class="trail-item" itemprop="itemListElement" itemscope="" itemtype="https://schema.org/ListItem"><a href="https://trendoceans.com/category/topic/" itemtype="https://schema.org/Thing" itemprop="item"><span itemprop="name">Topic</span></a><span class="breadcrumb-sep">&gt;</span><meta content="2" itemprop="position"/></li><li class="trail-item trail-end" itemprop="itemListElement" itemscope="" itemtype="https://schema.org/ListItem"><a href="https://trendoceans.com/arch2appimage/" itemtype="https://schema.org/Thing" itemprop="item"><span itemprop="name">Arch2appimage: Convert Arch Package into Appimage using Python Script on Linux</span></a><meta content="3" itemprop="position"/></li></ol></nav>
	</div><!-- .page-header-inner -->

	
	
</header><!-- .page-header -->


	
	<div id="content-wrap" class="container clr">

		
		<div id="primary" class="content-area clr">

			
			<div id="content" class="site-content clr">

				
				
<article id="post-27982">

	

<header class="entry-header clr">
	<h1 class="single-post-title entry-title" itemprop="headline">Arch2appimage: Convert Arch Package into Appimage using Python Script on Linux</h1><!-- .single-post-title -->
</header><!-- .entry-header -->


<ul class="meta ospm-none clr">

	
		
		
					<li class="meta-mod-date" itemprop="dateModified"><span class="screen-reader-text">Post last modified:</span><i class=" icon-note" aria-hidden="true" role="img"></i>September 4, 2022</li>
		
		
		
		
	
					<li class="meta-author" itemprop="name"><span class="screen-reader-text">Post author:</span><i class=" icon-user" aria-hidden="true" role="img"></i><a href="https://trendoceans.com/author/admin/" title="Posts by Jake Redfield" rel="author" itemprop="author" itemscope="itemscope" itemtype="https://schema.org/Person">Jake Redfield</a></li>
		
		
		
		
		
		
	
		
		
		
		
		
					<li class="meta-comments"><span class="screen-reader-text">Post comments:</span><i class=" icon-bubble" aria-hidden="true" role="img"></i><a href="https://trendoceans.com/arch2appimage/#respond" class="comments-link">0 Comments</a></li>
		
	
</ul>



<div class="entry-content clr" itemprop="text">
	
<p>If you are using Arch Linux due to a specific package being only available in that distribution, then it’s time for you to move on with that package.</p>



<p><strong><strong>What am I talking about?</strong></strong> You might be thinking about what I’ve just said. Look, you and I both know that Arch or its derivatives like Manjaro and Endeavour, are community-driven and have the largest software repository.</p>



<p>It’s been a long time since I’ve used Arch or any of its derivates, but as I recall, I remember there were many packages that were not available for other distributions and vice-versa.</p>



<p>However, if you are using an Arch-based system just because your favourite package is not available for another distribution like Debian, Ubuntu, RHEL, Fedora, etc, then it’s time for you to move your package to those distributions using <a href="#intro">Arch2appimage</a>.</p>



<div id="ez-toc-container" class="ez-toc-v2_0_33_2 counter-hierarchy ez-toc-counter ez-toc-light-blue ez-toc-container-direction">
<div class="ez-toc-title-container">
<p class="ez-toc-title">Table of Contents</p>
<span class="ez-toc-title-toggle"></span></div>
<nav><ul class="ez-toc-list ez-toc-list-level-1"><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-1" href="#What_is_the_Arch2appimage_Tool_in_Arch_Linux" title="What is the Arch2appimage Tool in Arch Linux?">What is the Arch2appimage Tool in Arch Linux?</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-2" href="#How_to_Install_Arch2appimage_on_Arch_Linux" title="How to Install Arch2appimage on Arch Linux">How to Install Arch2appimage on Arch Linux</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-3" href="#Convert_Arch_Packages_into_Appimage_Format_using_Arch2appimage" title="Convert Arch Packages into Appimage Format using Arch2appimage">Convert Arch Packages into Appimage Format using Arch2appimage</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-4" href="#Wrap_Up" title="Wrap Up">Wrap Up</a></li></ul></nav></div>
<h2 id="intro"><span class="ez-toc-section" id="What_is_the_Arch2appimage_Tool_in_Arch_Linux"></span>What is the Arch2appimage Tool in Arch Linux?<span class="ez-toc-section-end"></span></h2>



<p>The Arch2appimage (inspired by <a href="https://github.com/ivan-hc/Arch-Deployer" target="_blank" rel="noreferrer noopener">Arch-Deployer</a>) is a free and open-source script or tool written in Python with the goal of converting Arch Linux packages either from the official Arch Linux Repositories or from the AUR into Appimage.</p>



<p>As you already know, Appimage is mostly supported by all popular Linux distributions. Why? Because it includes the package and all its dependencies inside the sandboxed package, isolated from your Linux system.</p>



<p>When you execute this tool, it will ask for the package name and then compile the package and create an Appimage format including all necessary dependencies, including dependencies on dependencies for better compatibility.</p>



<p>Remember, to use this tool you have to have an Arch-based system like Manjaro or Endeavour. Because it uses the <a href="https://trendoceans.com/install-yay-aur-helper-in-arch-and-manjaro-linux/">Yay package manager</a> under the shell to download the package. However, if you are a developer, you can easily modify the script according to your personal needs.</p>



<p>With that due, let’s move into the next section on the <a href="#install">installation of this tool</a>.</p>



<h2 id="install"><span class="ez-toc-section" id="How_to_Install_Arch2appimage_on_Arch_Linux"></span>How to Install Arch2appimage on Arch Linux<span class="ez-toc-section-end"></span></h2>



<p>To install this tool, make sure you have Python3, <a href="https://trendoceans.com/how-to-install-python-pip-on-windows-macos-and-linux/">Pip3</a>, and Git installed on your system.</p>



<p>Then run the following command to clone the Arch2appimage repository:</p>



<pre class="wp-block-code"><code><strong>$ git clone https://github.com/hanzala123/arch2appimage</strong></code></pre>



<p>Below is the output of the above command.</p>



<figure class="wp-block-image size-large"><a href="https://trendoceans.com/wp-content/uploads/2022/09/Cloning-git-repository.webp"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMDI0IiBoZWlnaHQ9IjE1OCIgdmlld0JveD0iMCAwIDEwMjQgMTU4Ij48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBmaWxsPSIjY2ZkNGRiIi8+PC9zdmc+" width="1024" height="158" data-src="https://trendoceans.com/wp-content/uploads/2022/09/Cloning-git-repository-1024x158.webp" alt="Cloning git repository" class="wp-image-28012" data-srcset="https://trendoceans.com/wp-content/uploads/2022/09/Cloning-git-repository-1024x158.webp 1024w, https://trendoceans.com/wp-content/uploads/2022/09/Cloning-git-repository-300x46.webp 300w, https://trendoceans.com/wp-content/uploads/2022/09/Cloning-git-repository-768x119.webp 768w, https://trendoceans.com/wp-content/uploads/2022/09/Cloning-git-repository-1536x237.webp 1536w, https://trendoceans.com/wp-content/uploads/2022/09/Cloning-git-repository.webp 1851w" data-sizes="(max-width: 1024px) 100vw, 1024px"/><noscript><img width="1024" height="158" src="https://trendoceans.com/wp-content/uploads/2022/09/Cloning-git-repository-1024x158.webp" alt="Cloning git repository" class="wp-image-28012" srcset="https://trendoceans.com/wp-content/uploads/2022/09/Cloning-git-repository-1024x158.webp 1024w, https://trendoceans.com/wp-content/uploads/2022/09/Cloning-git-repository-300x46.webp 300w, https://trendoceans.com/wp-content/uploads/2022/09/Cloning-git-repository-768x119.webp 768w, https://trendoceans.com/wp-content/uploads/2022/09/Cloning-git-repository-1536x237.webp 1536w, https://trendoceans.com/wp-content/uploads/2022/09/Cloning-git-repository.webp 1851w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></a><figcaption><strong><em>Cloning git repository</em></strong></figcaption></figure>



<p>Enter into the tool directory using the <a href="https://trendoceans.com/30-basic-commands-which-every-linux-user-should-know/">cd command</a> as shown.</p>



<pre class="wp-block-code"><code><strong>$ cd arch2appimage/</strong></code></pre>



<p>Download and install all the required Python libraries for this tool.</p>



<pre class="wp-block-code"><code><strong>$ pip3 install -r requirements.txt</strong></code></pre>



<p> Below is the output of the above command.</p>


<div class="wp-block-image">
<figure class="aligncenter size-large"><a href="https://trendoceans.com/wp-content/uploads/2022/09/Installing-python-requried-libararies.webp"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMDI0IiBoZWlnaHQ9IjQ3MCIgdmlld0JveD0iMCAwIDEwMjQgNDcwIj48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBmaWxsPSIjY2ZkNGRiIi8+PC9zdmc+" width="1024" height="470" data-src="https://trendoceans.com/wp-content/uploads/2022/09/Installing-python-requried-libararies-1024x470.webp" alt="Installing python required libraries" class="wp-image-28013" data-srcset="https://trendoceans.com/wp-content/uploads/2022/09/Installing-python-requried-libararies-1024x470.webp 1024w, https://trendoceans.com/wp-content/uploads/2022/09/Installing-python-requried-libararies-300x138.webp 300w, https://trendoceans.com/wp-content/uploads/2022/09/Installing-python-requried-libararies-768x353.webp 768w, https://trendoceans.com/wp-content/uploads/2022/09/Installing-python-requried-libararies-1536x705.webp 1536w, https://trendoceans.com/wp-content/uploads/2022/09/Installing-python-requried-libararies.webp 1851w" data-sizes="(max-width: 1024px) 100vw, 1024px"/><noscript><img width="1024" height="470" src="https://trendoceans.com/wp-content/uploads/2022/09/Installing-python-requried-libararies-1024x470.webp" alt="Installing python required libraries" class="wp-image-28013" srcset="https://trendoceans.com/wp-content/uploads/2022/09/Installing-python-requried-libararies-1024x470.webp 1024w, https://trendoceans.com/wp-content/uploads/2022/09/Installing-python-requried-libararies-300x138.webp 300w, https://trendoceans.com/wp-content/uploads/2022/09/Installing-python-requried-libararies-768x353.webp 768w, https://trendoceans.com/wp-content/uploads/2022/09/Installing-python-requried-libararies-1536x705.webp 1536w, https://trendoceans.com/wp-content/uploads/2022/09/Installing-python-requried-libararies.webp 1851w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></a><figcaption><strong><em>Installing Python required libraries</em></strong></figcaption></figure></div>


<p>That’s all for now. Now you can move into the next section and <a href="#meat">start packaging your favourite Arch package into Appimage</a>.</p>



<h2 id="meat"><span class="ez-toc-section" id="Convert_Arch_Packages_into_Appimage_Format_using_Arch2appimage"></span>Convert Arch Packages into Appimage Format using Arch2appimage<span class="ez-toc-section-end"></span></h2>



<p>First, launch the application using Python3.</p>



<pre class="wp-block-code"><code><strong>$ python3 arch2appimage.py</strong></code></pre>



<p>Then you will interact with the following screen.</p>


<div class="wp-block-image">
<figure class="aligncenter size-large"><a href="https://trendoceans.com/wp-content/uploads/2022/09/Arch2appimage-interact.webp"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMDI0IiBoZWlnaHQ9IjEzMCIgdmlld0JveD0iMCAwIDEwMjQgMTMwIj48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBmaWxsPSIjY2ZkNGRiIi8+PC9zdmc+" width="1024" height="130" data-src="https://trendoceans.com/wp-content/uploads/2022/09/Arch2appimage-interact-1024x130.webp" alt="Arch2appimage" class="wp-image-28018" data-srcset="https://trendoceans.com/wp-content/uploads/2022/09/Arch2appimage-interact-1024x130.webp 1024w, https://trendoceans.com/wp-content/uploads/2022/09/Arch2appimage-interact-300x38.webp 300w, https://trendoceans.com/wp-content/uploads/2022/09/Arch2appimage-interact-768x98.webp 768w, https://trendoceans.com/wp-content/uploads/2022/09/Arch2appimage-interact-1536x196.webp 1536w, https://trendoceans.com/wp-content/uploads/2022/09/Arch2appimage-interact.webp 1861w" data-sizes="(max-width: 1024px) 100vw, 1024px"/><noscript><img width="1024" height="130" src="https://trendoceans.com/wp-content/uploads/2022/09/Arch2appimage-interact-1024x130.webp" alt="Arch2appimage" class="wp-image-28018" srcset="https://trendoceans.com/wp-content/uploads/2022/09/Arch2appimage-interact-1024x130.webp 1024w, https://trendoceans.com/wp-content/uploads/2022/09/Arch2appimage-interact-300x38.webp 300w, https://trendoceans.com/wp-content/uploads/2022/09/Arch2appimage-interact-768x98.webp 768w, https://trendoceans.com/wp-content/uploads/2022/09/Arch2appimage-interact-1536x196.webp 1536w, https://trendoceans.com/wp-content/uploads/2022/09/Arch2appimage-interact.webp 1861w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></a><figcaption><strong><em>Arch2appimage</em></strong></figcaption></figure></div>


<p>As you look above, you will notice that the program is asking for the Arch package name. </p>



<p>In this case, I want to create an Appimage for the gnome-terminal from the Arch repository. For that, I will pass the <strong><code>gnome-terminal</code></strong> as input to the program.</p>



<pre class="wp-block-code"><code><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong>Enter the name of the package (leave empty to quit)
[</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-luminous-vivid-orange-color"><strong>?</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong>] &gt;&gt;: gnome-terminal</strong></mark></code></pre>



<blockquote class="wp-block-quote"><p><strong><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-vivid-red-color">Note</mark></strong>: Replace <strong><code>gnome-terminal</code></strong> with the actual package name that you want to create an Appimage for.</p></blockquote>



<p>It will download the package from the Arch repository and ask you to choose an icon to be used for your application. For <strong><code>gnome-terminal</code></strong>, there are three options, but it varies from package to package. Just go with your intuition and choose the one you find more relevant.</p>



<pre class="wp-block-code"><code><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong>Downloading gnome-terminal...
   </strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-luminous-vivid-amber-color"><strong>━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong> </strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-vivid-green-cyan-color"><strong>1.2/1.2 MB</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong> • </strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-vivid-red-color"><strong>961.5 kB/s</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong> • 0:00:00   

Please select the icon file to be used
[</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-luminous-vivid-orange-color"><strong>?</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong>] &gt;&gt;: AppDir/usr/share/icons/hicolor/scalable/apps/org.gnome.Terminal.svg
</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-vivid-cyan-blue-color"><strong> &gt; AppDir/usr/share/icons/hicolor/scalable/apps/org.gnome.Terminal.svg</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong>
   AppDir/usr/share/icons/hicolor/symbolic/apps/org.gnome.Terminal-symbolic.svg
=</strong></mark></code></pre>



<p>Next, it will show you the list of packages to be downloaded to support this application. If you have any additional packages to add, then specify them by typing their names, or else press <strong><kbd>ENTER</kbd></strong> to continue.</p>



<pre class="wp-block-code"><code><strong><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">These packages (and their dependencies) will be downloaded:
1. vte3
2. gsettings-desktop-schemas

If you would like to add additional packages please enter them below (space seperated). Leave empty to start downloading
[</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-luminous-vivid-orange-color">?</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">] &gt;&gt;: </mark></strong></code></pre>



<p>It will now download the supporting packages.</p>



<pre class="wp-block-code"><code><strong><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">Downloading vte3...
   <mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong>   </strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-luminous-vivid-amber-color"><strong>━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong> </strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-vivid-green-cyan-color"><strong>1.2/1.2 MB</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong> • </strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-vivid-red-color"><strong>961.5 kB/s</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong> • 0:00:00   </strong></mark> 
Downloading gsettings-desktop-schemas...
   <mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong>   </strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-luminous-vivid-amber-color"><strong>━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong> </strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-vivid-green-cyan-color"><strong>1.2/1.2 MB</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong> • </strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-vivid-red-color"><strong>961.5 kB/s</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong> • 0:00:00   </strong></mark>  </mark></strong></code></pre>



<p>It will ask you to download the latest version of the <strong><code>libunionpreload.so</code></strong> package or use the existing one. For now, I will choose “<strong><code>yes</code></strong>” to download the latest version of the <strong><code>libunionpreload.so</code></strong> package.</p>



<pre class="wp-block-code"><code><strong><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">Would you like to download the latest libunionpreload.so? If you select No the existing one will be used.
[</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-luminous-vivid-orange-color">?</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">] &gt;&gt;: Yes
</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-vivid-cyan-blue-color"> &gt; Yes</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">
   No

Downloading libunionpreload.so...
   <strong><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">   <mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong>   </strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-luminous-vivid-amber-color"><strong>━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong> </strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-vivid-green-cyan-color"><strong>1.2/1.2 MB</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong> • </strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-vivid-red-color"><strong>961.5 kB/s</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong> • 0:00:00   </strong></mark> </mark></strong>
AppDir is ready. Please take a look into the directory to ensure everything is OK.
Exec the AppRun (command &#39;./AppRun&#39;) to test if everything works.</mark></strong></code></pre>



<p>Finally, your package is ready to be converted into Appimage format. All the resources for your packages, like source code and dependencies, are downloaded and located in the <strong><code>arch2appimage/AppDir</code></strong> directory.</p>



<p>At the next prompt, it will ask you to either <strong><code>build the AppImage</code></strong> or <strong><code>Add more packages</code></strong>. For now, there is no extra package I need to add, so I will continue with the <strong><code>Build the AppImage</code></strong> option.</p>



<pre class="wp-block-code"><code><strong><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">What would you like to do next?
[</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-luminous-vivid-orange-color">?</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">] &gt;&gt;: Build the AppImage
</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-vivid-cyan-blue-color"> &gt; Build the AppImage</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">
   Add more packages</mark></strong></code></pre>



<p>Next, it will ask you to choose the latest AppImageTool to build your Appimage (used to generate Appimage files) or the existing one. For instance, I will go with “<strong><code>yes</code></strong>“.</p>



<pre class="wp-block-code"><code><strong><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">Would you like to download the latest AppImageTool? If you select No the existing one will be used.
[</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-luminous-vivid-orange-color">?</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">] &gt;&gt;: Yes
</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-vivid-cyan-blue-color"> &gt; Yes</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">
   No

Downloading AppImageTool...
   <strong><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">   <strong><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">   <mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong>   </strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-luminous-vivid-amber-color"><strong>━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong> </strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-vivid-green-cyan-color"><strong>1.2/1.2 MB</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong> • </strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-vivid-red-color"><strong>961.5 kB/s</strong></mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color"><strong> • 0:00:00   </strong></mark> </mark></strong></mark></strong>
Running AppImageTool...

Created symlink /home/jr/.config/systemd/user/default.target.wants/appimagelauncherd.service → /usr/lib/systemd/user/appimagelauncherd.service.
[AppImageLauncher] Warning: can&#39;t find fallback icon for namedialog-ok
[AppImageLauncher] Warning: can&#39;t find fallback icon for namedialog-cancel
[AppImageLauncher] Warning: can&#39;t find fallback icon for namedocument-revert
appimagetool, continuous build (commit 4bcfe23), build &lt;local dev build&gt; built on 2022-08-17 01:03:50 UTC
Using architecture x86_64
/home/jr/arch2appimage/AppDir should be packaged as out/gnome-terminal-x86_64.AppImage
Deleting pre-existing .DirIcon
Creating .DirIcon symlink based on information from desktop file
Generating squashfs...
Parallel mksquashfs: Using 4 processors
Creating 4.0 filesystem on out/gnome-terminal-x86_64.AppImage, block size 131072.
[==================================================================================================================================================-] 985/985 100%

Exportable Squashfs 4.0 filesystem, gzip compressed, data block size 131072
        compressed data, compressed metadata, compressed fragments,
        compressed xattrs, compressed ids
        duplicates are removed
Filesystem size 4037.33 Kbytes (3.94 Mbytes)
        27.38% of uncompressed filesystem size (14743.19 Kbytes)
Inode table size 12519 bytes (12.23 Kbytes)
        27.21% of uncompressed inode table size (46012 bytes)
Directory table size 9384 bytes (9.16 Kbytes)
        25.97% of uncompressed directory table size (36131 bytes)
Number of duplicate files found 4
Number of inodes 1350
Number of files 971
Number of fragments 129
Number of symbolic links  60
Number of device nodes 0
Number of fifo nodes 0
Number of socket nodes 0
Number of directories 319</mark></strong></code></pre>



<p>Congratulation! The gnome-terminal is converted into Appimage format and waiting for you in the <code><strong>arch2appimage/out</strong></code> directory.</p>



<p>But hold on, it will again prompt you to “<strong><code>Would you like to re-build it?</code></strong>“. Simply go with the “<strong><code>no</code></strong>” option.</p>



<pre class="wp-block-code"><code><strong><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">Would you like to re-build it?
[</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-luminous-vivid-orange-color">?</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">] &gt;&gt;: No
   Yes
</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-vivid-cyan-blue-color"> &gt; No</mark></strong></code></pre>



<p>Finally, choose “<strong><code>yes</code></strong>” to remove all the resources from <strong><code>AppDir/</code></strong> that are no longer required.</p>



<pre class="wp-block-code"><code><strong><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">Would you like to remove AppDir/
[</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-luminous-vivid-orange-color">?</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">] &gt;&gt;: Yes
</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-vivid-cyan-blue-color"> &gt; Yes</mark><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">
   No</mark></strong>

<strong><mark style="background-color:rgba(0, 0, 0, 0)" class="has-inline-color has-light-green-cyan-color">Exiting...</mark></strong></code></pre>



<p>In the same Arch2appimage cloned directory, you will find the <strong><code>/out</code></strong> directory. You can check your Appimage inside that directory by using the <strong><code>cd</code></strong> and <strong><code>ls</code></strong> commands.</p>



<pre class="wp-block-code"><code><strong>$ cd out/
$ ls -l</strong></code></pre>



<p>Below is the output of the above commands.</p>


<div class="wp-block-image">
<figure class="aligncenter size-large"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMDI0IiBoZWlnaHQ9IjEwNCIgdmlld0JveD0iMCAwIDEwMjQgMTA0Ij48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBmaWxsPSIjY2ZkNGRiIi8+PC9zdmc+" width="1024" height="104" data-src="https://trendoceans.com/wp-content/uploads/2022/09/Checking-the-content-of-the-out-directory-1024x104.webp" alt="Checking the content of the out directory" class="wp-image-28041" data-srcset="https://trendoceans.com/wp-content/uploads/2022/09/Checking-the-content-of-the-out-directory-1024x104.webp 1024w, https://trendoceans.com/wp-content/uploads/2022/09/Checking-the-content-of-the-out-directory-300x30.webp 300w, https://trendoceans.com/wp-content/uploads/2022/09/Checking-the-content-of-the-out-directory-768x78.webp 768w, https://trendoceans.com/wp-content/uploads/2022/09/Checking-the-content-of-the-out-directory-1536x155.webp 1536w, https://trendoceans.com/wp-content/uploads/2022/09/Checking-the-content-of-the-out-directory.webp 1860w" data-sizes="(max-width: 1024px) 100vw, 1024px"/><noscript><img width="1024" height="104" src="https://trendoceans.com/wp-content/uploads/2022/09/Checking-the-content-of-the-out-directory-1024x104.webp" alt="Checking the content of the out directory" class="wp-image-28041" srcset="https://trendoceans.com/wp-content/uploads/2022/09/Checking-the-content-of-the-out-directory-1024x104.webp 1024w, https://trendoceans.com/wp-content/uploads/2022/09/Checking-the-content-of-the-out-directory-300x30.webp 300w, https://trendoceans.com/wp-content/uploads/2022/09/Checking-the-content-of-the-out-directory-768x78.webp 768w, https://trendoceans.com/wp-content/uploads/2022/09/Checking-the-content-of-the-out-directory-1536x155.webp 1536w, https://trendoceans.com/wp-content/uploads/2022/09/Checking-the-content-of-the-out-directory.webp 1860w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript><figcaption><strong><em>Checking the content of the out directory</em></strong></figcaption></figure></div>


<h2><span class="ez-toc-section" id="Wrap_Up"></span>Wrap Up<span class="ez-toc-section-end"></span></h2>



<p>This method is useful for some packages that are exclusive to Arch-based distros. However, note that if you are creating an Appimage of a package that needs to be run on a specific desktop environment, then you should have to run the Appimage on that DE.</p>



<p>For example, I have created an Appimage of gnome-terminal. This method has included all of the dependencies that are required by this package. However, the gnome-terminal also requires some programs that come with the Gnome desktop environment.</p>



<p>So, if you run the Appimage in KDE, Xfce, etc, the desktop environment will throw an error. In this case, you need to run this Appimage only in the Gnome desktop environment, which you can easily convert from your current DE.</p>



<p>If you have encountered any issues or are facing any difficulty while using this program, then do let us know in the comment section.</p>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async="" data-uid="2537dda23d" src="https://colossal-maker-6147.ck.page/2537dda23d/index.js"></script><div class="saboxplugin-wrap" itemtype="http://schema.org/Person" itemscope="" itemprop="author"><div class="saboxplugin-tab"><div class="saboxplugin-gravatar"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTAwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" data-src="https://trendoceans.com/wp-content/uploads/2022/06/Frame-4.png" width="100" height="100" alt="Jake Redfield" itemprop="image"/><noscript><img src="https://trendoceans.com/wp-content/uploads/2022/06/Frame-4.png" width="100"  height="100" alt="Jake Redfield" itemprop="image"></noscript></div><div class="saboxplugin-authorname"><a href="https://trendoceans.com/author/admin/" class="vcard author" rel="author" itemprop="url"><span class="fn" itemprop="name">Jake Redfield</span></a></div><div class="saboxplugin-desc"><div itemprop="description"><p>Innovative tech mind with 12 years of experience working as a computer programmer, web developer, and security researcher. Capable of working with a variety of technology and software solutions, and managing databases.</p>
</div></div><div class="clearfix"></div><div class="saboxplugin-socials "><a target="_blank" href="https://www.facebook.com/heythisisvivek" aria-label="Facebook" rel="nofollow noopener" class="saboxplugin-icon-grey"><svg aria-hidden="true" class="sab-facebook" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 264 512"><path fill="currentColor" d="M76.7 512V283H0v-91h76.7v-71.7C76.7 42.4 124.3 0 193.8 0c33.3 0 61.9 2.5 70.2 3.6V85h-48.2c-37.8 0-45.1 18-45.1 44.3V192H256l-11.7 91h-73.6v229"></path></svg></a><a target="_blank" href="https://www.instagram.com/heythisisvivek" aria-label="Instagram" rel="nofollow noopener" class="saboxplugin-icon-grey"><svg aria-hidden="true" class="sab-instagram" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M224.1 141c-63.6 0-114.9 51.3-114.9 114.9s51.3 114.9 114.9 114.9S339 319.5 339 255.9 287.7 141 224.1 141zm0 189.6c-41.1 0-74.7-33.5-74.7-74.7s33.5-74.7 74.7-74.7 74.7 33.5 74.7 74.7-33.6 74.7-74.7 74.7zm146.4-194.3c0 14.9-12 26.8-26.8 26.8-14.9 0-26.8-12-26.8-26.8s12-26.8 26.8-26.8 26.8 12 26.8 26.8zm76.1 27.2c-1.7-35.9-9.9-67.7-36.2-93.9-26.2-26.2-58-34.4-93.9-36.2-37-2.1-147.9-2.1-184.9 0-35.8 1.7-67.6 9.9-93.9 36.1s-34.4 58-36.2 93.9c-2.1 37-2.1 147.9 0 184.9 1.7 35.9 9.9 67.7 36.2 93.9s58 34.4 93.9 36.2c37 2.1 147.9 2.1 184.9 0 35.9-1.7 67.7-9.9 93.9-36.2 26.2-26.2 34.4-58 36.2-93.9 2.1-37 2.1-147.8 0-184.8zM398.8 388c-7.8 19.6-22.9 34.7-42.6 42.6-29.5 11.7-99.5 9-132.1 9s-102.7 2.6-132.1-9c-19.6-7.8-34.7-22.9-42.6-42.6-11.7-29.5-9-99.5-9-132.1s-2.6-102.7 9-132.1c7.8-19.6 22.9-34.7 42.6-42.6 29.5-11.7 99.5-9 132.1-9s102.7-2.6 132.1 9c19.6 7.8 34.7 22.9 42.6 42.6 11.7 29.5 9 99.5 9 132.1s2.7 102.7-9 132.1z"></path></svg></a><a target="_blank" href="https://twitter.com/heythisisvivek" aria-label="Twitter" rel="nofollow noopener" class="saboxplugin-icon-grey"><svg aria-hidden="true" class="sab-twitter" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"></path></svg></a><a target="_blank" href="https://t.me/https://t.me/heythisisvivek" aria-label="Telegram" rel="nofollow noopener" class="saboxplugin-icon-grey"><svg aria-hidden="true" class="sab-telegram" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M 471.230469 156.445312 C 483.554688 185.835938 490.191406 216.179688 490.191406 248.414062 C 490.191406 280.652344 483.554688 310.992188 471.230469 340.386719 C 458.902344 369.777344 441.835938 394.429688 420.976562 416.238281 C 400.117188 437.097656 374.519531 454.164062 345.125 466.488281 C 315.734375 478.816406 285.394531 485.453125 253.15625 485.453125 C 220.917969 485.453125 190.578125 478.816406 161.183594 466.488281 C 131.792969 454.164062 107.140625 437.097656 85.332031 416.238281 C 64.472656 395.378906 47.40625 369.777344 35.082031 340.386719 C 22.753906 310.992188 16.117188 280.652344 16.117188 248.414062 C 16.117188 216.179688 22.753906 185.835938 35.082031 156.445312 C 47.40625 127.050781 64.472656 102.398438 85.332031 80.59375 C 106.191406 59.734375 131.792969 42.667969 161.183594 30.339844 C 190.578125 18.015625 220.917969 11.378906 253.15625 11.378906 C 285.394531 11.378906 315.734375 18.015625 345.125 30.339844 C 374.519531 42.667969 399.171875 59.734375 420.976562 80.59375 C 441.835938 102.398438 457.957031 128 471.230469 156.445312 Z M 329.957031 357.453125 L 368.828125 174.460938 C 370.726562 166.875 369.777344 161.183594 365.984375 157.394531 C 362.191406 153.601562 358.398438 153.601562 352.710938 155.496094 L 124.207031 243.675781 C 119.464844 245.570312 115.675781 247.464844 113.777344 250.3125 C 111.882812 253.15625 111.882812 255.050781 112.828125 256.949219 C 113.777344 258.84375 116.621094 260.742188 121.363281 261.6875 L 180.148438 279.703125 L 315.734375 194.371094 C 319.527344 191.527344 322.371094 191.527344 324.265625 192.472656 C 325.214844 193.421875 325.214844 194.371094 323.320312 196.265625 L 213.332031 296.769531 L 208.59375 357.453125 C 212.386719 357.453125 216.179688 355.554688 220.917969 351.761719 L 249.363281 324.265625 L 308.148438 367.882812 C 320.472656 374.519531 327.109375 370.726562 329.957031 357.453125 Z M 329.957031 357.453125 "></path></svg></a><a target="_self" href="/cdn-cgi/l/email-protection#087f677a636e677a6269636d486f65696164266b6765" aria-label="User email" rel="nofollow noopener" class="saboxplugin-icon-grey"><svg aria-hidden="true" class="sab-user_email" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M502.3 190.8c3.9-3.1 9.7-.2 9.7 4.7V400c0 26.5-21.5 48-48 48H48c-26.5 0-48-21.5-48-48V195.6c0-5 5.7-7.8 9.7-4.7 22.4 17.4 52.1 39.5 154.1 113.6 21.1 15.4 56.7 47.8 92.2 47.6 35.7.3 72-32.8 92.3-47.6 102-74.1 131.6-96.3 154-113.7zM256 320c23.2.4 56.6-29.2 73.4-41.4 132.7-96.3 142.8-104.7 173.4-128.7 5.8-4.5 9.2-11.5 9.2-18.9v-19c0-26.5-21.5-48-48-48H48C21.5 64 0 85.5 0 112v19c0 7.4 3.4 14.3 9.2 18.9 30.6 23.9 40.7 32.4 173.4 128.7 16.8 12.2 50.2 41.8 73.4 41.4z"></path></svg></a></div></div></div>
</div><!-- .entry -->


<div class="entry-share clr minimal side">

	
		<h3 class="theme-heading social-share-title">
			<span class="text" aria-hidden="true">Please Share This</span>
			<span class="screen-reader-text">Share this content</span>
		</h3>

	
	<ul class="oss-social-share clr" aria-label="Available sharing options">

		
				<li class="twitter">
					<a href="https://twitter.com/share?text=Arch2appimage%3A%20Convert%20Arch%20Package%20into%20Appimage%20using%20Python%20Script%20on%20Linux&amp;url=https%3A%2F%2Ftrendoceans.com%2Farch2appimage%2F" aria-label="Share on Twitter" onclick="oss_onClick( this.href );return false;">
						<span class="screen-reader-text">Opens in a new window</span>
						<span class="oss-icon-wrap">
							<svg class="oss-icon" role="img" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" focusable="false">
								<path d="M23.954 4.569c-.885.389-1.83.654-2.825.775 1.014-.611 1.794-1.574 2.163-2.723-.951.555-2.005.959-3.127 1.184-.896-.959-2.173-1.559-3.591-1.559-2.717 0-4.92 2.203-4.92 4.917 0 .39.045.765.127 1.124C7.691 8.094 4.066 6.13 1.64 3.161c-.427.722-.666 1.561-.666 2.475 0 1.71.87 3.213 2.188 4.096-.807-.026-1.566-.248-2.228-.616v.061c0 2.385 1.693 4.374 3.946 4.827-.413.111-.849.171-1.296.171-.314 0-.615-.03-.916-.086.631 1.953 2.445 3.377 4.604 3.417-1.68 1.319-3.809 2.105-6.102 2.105-.39 0-.779-.023-1.17-.067 2.189 1.394 4.768 2.209 7.557 2.209 9.054 0 13.999-7.496 13.999-13.986 0-.209 0-.42-.015-.63.961-.689 1.8-1.56 2.46-2.548l-.047-.02z"></path>
							</svg>
						</span>
											</a>
				</li>

			
		
				<li class="facebook">
					<a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ftrendoceans.com%2Farch2appimage%2F" aria-label="Share on Facebook" onclick="oss_onClick( this.href );return false;">
						<span class="screen-reader-text">Opens in a new window</span>
						<span class="oss-icon-wrap">
							<svg class="oss-icon" role="img" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" focusable="false">
								<path d="M5.677,12.998V8.123h3.575V6.224C9.252,2.949,11.712,0,14.736,0h3.94v4.874h-3.94
								c-0.432,0-0.934,0.524-0.934,1.308v1.942h4.874v4.874h-4.874V24H9.252V12.998H5.677z"></path>
							</svg>
						</span>
											</a>
				</li>

			
		
				<li class="linkedin">
					<a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Ftrendoceans.com%2Farch2appimage%2F&amp;title=Arch2appimage%3A%20Convert%20Arch%20Package%20into%20Appimage%20using%20Python%20Script%20on%20Linux&amp;summary=If+you+are+using+Arch+Linux+due+to+a+specific+package+being+only+available+in+that+distribution%2C+then+it%E2%80%99s+time+for+you+to+move+on+with+that+package.+What+am+I+talking+about%3F+You+might+be+thinking+about+what+I%E2%80%99ve%26hellip%3B&amp;source=https://trendoceans.com/" aria-label="Share on LinkedIn" onclick="oss_onClick( this.href );return false;">
					<span class="screen-reader-text">Opens in a new window</span>
						<span class="oss-icon-wrap">
							<svg class="oss-icon" role="img" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" focusable="false">
								<path d="M6.52,22h-4.13V8.667h4.13V22z M4.436,6.92
								c-1.349,0-2.442-1.101-2.442-2.46C1.994,3.102,3.087,2,4.436,2s2.442,1.102,2.442,2.46C6.877,5.819,5.784,6.92,4.436,6.92z
								M21.994,22h-4.109c0,0,0-5.079,0-6.999c0-1.919-0.73-2.991-2.249-2.991c-1.652,0-2.515,1.116-2.515,2.991c0,2.054,0,6.999,0,6.999
								h-3.96V8.667h3.96v1.796c0,0,1.191-2.202,4.02-2.202c2.828,0,4.853,1.727,4.853,5.298C21.994,17.129,21.994,22,21.994,22z"></path>
							</svg>
						</span>
											</a>
				</li>

			
		
				<li class="reddit">
					<a href="https://www.reddit.com/submit?url=https%3A%2F%2Ftrendoceans.com%2Farch2appimage%2F&amp;title=Arch2appimage%3A%20Convert%20Arch%20Package%20into%20Appimage%20using%20Python%20Script%20on%20Linux" aria-label="Share on Reddit" onclick="oss_onClick( this.href );return false;">
						<span class="screen-reader-text">Opens in a new window</span>
						<span class="oss-icon-wrap">
							<svg class="oss-icon" role="img" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" focusable="false">
								<path d="M23.999,11.786c0-1.576-1.294-2.858-2.885-2.858c-0.689,0-1.321,0.241-1.817,0.641
								c-1.759-1.095-3.991-1.755-6.383-1.895l1.248-3.91l3.43,0.8c0.09,1.237,1.134,2.217,2.405,2.217c1.33,0,2.412-1.072,2.412-2.391
								c0-1.318-1.082-2.39-2.412-2.39c-0.93,0-1.739,0.525-2.141,1.291l-3.985-0.93c-0.334-0.078-0.671,0.112-0.775,0.436L11.547,7.65
								C8.969,7.712,6.546,8.375,4.658,9.534c-0.49-0.38-1.105-0.607-1.774-0.607C1.293,8.927,0,10.209,0,11.785
								c0,0.974,0.495,1.836,1.249,2.351c-0.031,0.227-0.048,0.455-0.048,0.686c0,1.97,1.156,3.803,3.254,5.16
								C6.468,21.283,9.13,22,11.952,22s5.485-0.716,7.496-2.018c2.099-1.357,3.254-3.19,3.254-5.16c0-0.21-0.014-0.419-0.041-0.626
								C23.464,13.689,23.999,12.798,23.999,11.786 M19.997,3.299c0.607,0,1.102,0.49,1.102,1.091c0,0.602-0.494,1.092-1.102,1.092
								s-1.102-0.49-1.102-1.092C18.896,3.789,19.389,3.299,19.997,3.299 M6.805,13.554c0-0.888,0.752-1.633,1.648-1.633
								c0.897,0,1.625,0.745,1.625,1.633c0,0.889-0.728,1.61-1.625,1.61C7.557,15.163,6.805,14.442,6.805,13.554 M15.951,18.288
								c-0.836,0.827-2.124,1.229-3.939,1.229c-0.004,0-0.008-0.001-0.013-0.001c-0.004,0-0.008,0.001-0.013,0.001
								c-1.815,0-3.103-0.402-3.938-1.229c-0.256-0.254-0.256-0.665,0-0.919c0.256-0.253,0.671-0.253,0.927,0
								c0.576,0.571,1.561,0.849,3.01,0.849c0.005,0,0.009,0.001,0.013,0.001c0.005,0,0.009-0.001,0.013-0.001
								c1.45,0,2.435-0.278,3.012-0.849c0.256-0.254,0.671-0.253,0.927,0C16.206,17.623,16.206,18.034,15.951,18.288 M15.569,15.163
								c-0.897,0-1.651-0.721-1.651-1.61s0.754-1.633,1.651-1.633s1.625,0.745,1.625,1.633C17.193,14.442,16.466,15.163,15.569,15.163"></path>
							</svg>
						</span>
											</a>
				</li>

			
		
				<li class="whatsapp">
					<a href="whatsapp://send?text=https%3A%2F%2Ftrendoceans.com%2Farch2appimage%2F" aria-label="Share on WhatsApp" onclick="oss_onClick( this.href );return false;" data-action="share/whatsapp/share">
						<span class="screen-reader-text">Opens in a new window</span>
						<span class="oss-icon-wrap">
							<svg class="oss-icon" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 90 90" aria-hidden="true" focusable="false">
								<path id="WhatsApp" d="M90,43.841c0,24.213-19.779,43.841-44.182,43.841c-7.747,0-15.025-1.98-21.357-5.455L0,90l7.975-23.522
									c-4.023-6.606-6.34-14.354-6.34-22.637C1.635,19.628,21.416,0,45.818,0C70.223,0,90,19.628,90,43.841z M45.818,6.982
									c-20.484,0-37.146,16.535-37.146,36.859c0,8.065,2.629,15.534,7.076,21.61L11.107,79.14l14.275-4.537
									c5.865,3.851,12.891,6.097,20.437,6.097c20.481,0,37.146-16.533,37.146-36.857S66.301,6.982,45.818,6.982z M68.129,53.938
									c-0.273-0.447-0.994-0.717-2.076-1.254c-1.084-0.537-6.41-3.138-7.4-3.495c-0.993-0.358-1.717-0.538-2.438,0.537
									c-0.721,1.076-2.797,3.495-3.43,4.212c-0.632,0.719-1.263,0.809-2.347,0.271c-1.082-0.537-4.571-1.673-8.708-5.333
									c-3.219-2.848-5.393-6.364-6.025-7.441c-0.631-1.075-0.066-1.656,0.475-2.191c0.488-0.482,1.084-1.255,1.625-1.882
									c0.543-0.628,0.723-1.075,1.082-1.793c0.363-0.717,0.182-1.344-0.09-1.883c-0.27-0.537-2.438-5.825-3.34-7.977
									c-0.902-2.15-1.803-1.792-2.436-1.792c-0.631,0-1.354-0.09-2.076-0.09c-0.722,0-1.896,0.269-2.889,1.344
									c-0.992,1.076-3.789,3.676-3.789,8.963c0,5.288,3.879,10.397,4.422,11.113c0.541,0.716,7.49,11.92,18.5,16.223
									C58.2,65.771,58.2,64.336,60.186,64.156c1.984-0.179,6.406-2.599,7.312-5.107C68.398,56.537,68.398,54.386,68.129,53.938z"></path>
							</svg>
						</span>
											</a>
				</li>

			
		
	</ul>

</div><!-- .entry-share -->



<section id="comments" class="comments-area clr has-comments">

	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/arch2appimage/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://trendoceans.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate=""><div class="comment-textarea"><label for="comment" class="screen-reader-text">Comment</label><textarea name="comment" id="comment" cols="39" rows="4" tabindex="0" class="textarea-comment" placeholder="Your comment here..."></textarea></div><div class="comment-form-author"><label for="author" class="screen-reader-text">Enter your name or username to comment</label><input type="text" name="author" id="author" value="" placeholder="Name (required)" size="22" tabindex="0" aria-required="true" class="input-name"/></div>
<div class="comment-form-email"><label for="email" class="screen-reader-text">Enter your email address to comment</label><input type="text" name="email" id="email" value="" placeholder="Email (required)" size="22" tabindex="0" aria-required="true" class="input-email"/></div>
<div class="comment-form-url"><label for="url" class="screen-reader-text">Enter your website URL (optional)</label><input type="text" name="url" id="url" value="" placeholder="Website" size="22" tabindex="0" class="input-website"/></div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes"/> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="comment-form-comment-subscribe"><label for="cren_subscribe_to_comment"><input id="cren_subscribe_to_comment" name="cren_subscribe_to_comment" type="checkbox" value="on" checked=""/>Notify me via e-mail if anyone answers my comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment"/> <input type="hidden" name="comment_post_ID" value="27982" id="comment_post_ID"/>
<input type="hidden" name="comment_parent" id="comment_parent" value="0"/>
</p></form>	</div><!-- #respond -->
	
</section><!-- #comments -->

</article>

				
			</div><!-- #content -->

			
		</div><!-- #primary -->

		

<aside id="right-sidebar" class="sidebar-container widget-area sidebar-primary" itemscope="itemscope" itemtype="https://schema.org/WPSideBar" role="complementary" aria-label="Primary Sidebar">

	
	<div id="right-sidebar-inner" class="clr">

		<div id="block-6" class="sidebar-box widget_block clr"><p><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async="" data-uid="2cb259d534" src="https://colossal-maker-6147.ck.page/2cb259d534/index.js"></script></p>
</div><div id="search-2" class="sidebar-box widget_search clr"><h4 class="widget-title">Don’t find what you are looking for?</h4>
<form role="search" method="get" class="searchform" action="https://trendoceans.com/">
	<label for="ocean-search-form-2">
		<span class="screen-reader-text">Search this website</span>
		<input type="search" id="ocean-search-form-2" class="field" autocomplete="off" placeholder="Search" name="s"/>
			</label>
	</form>
</div><div id="ocean_recent_posts-3" class="sidebar-box widget-oceanwp-recent-posts recent-posts-widget clr"><h4 class="widget-title">Featured Post</h4>
				<ul class="oceanwp-recent-posts clr">

					
							<li class="clr">

																	<a href="https://trendoceans.com/uncover-linux/" title="Uncover: Quickly Discover Exposed Hosts on the Internet from Linux" class="recent-posts-thumbnail">
										<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNTAiIGhlaWdodD0iMTUwIiB2aWV3Qm94PSIwIDAgMTUwIDE1MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="150" height="150" data-src="https://trendoceans.com/wp-content/uploads/2022/08/uncover-150x150.webp" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Uncover: Quickly Discover Exposed Hosts on the Internet from Linux" itemprop="image" loading="lazy" data-srcset="https://trendoceans.com/wp-content/uploads/2022/08/uncover-150x150.webp 150w, https://trendoceans.com/wp-content/uploads/2022/08/uncover-600x600.webp 600w" data-sizes="(max-width: 150px) 100vw, 150px"/><noscript><img width="150" height="150" src="https://trendoceans.com/wp-content/uploads/2022/08/uncover-150x150.webp" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Uncover: Quickly Discover Exposed Hosts on the Internet from Linux" itemprop="image" loading="lazy" srcset="https://trendoceans.com/wp-content/uploads/2022/08/uncover-150x150.webp 150w, https://trendoceans.com/wp-content/uploads/2022/08/uncover-600x600.webp 600w" sizes="(max-width: 150px) 100vw, 150px" /></noscript>
										<span class="overlay"></span>
									</a>
								
								<div class="recent-posts-details clr">

									<div class="recent-posts-details-inner clr">

										<a href="https://trendoceans.com/uncover-linux/" class="recent-posts-title">Uncover: Quickly Discover Exposed Hosts on the Internet from Linux</a>

										<div class="recent-posts-info clr">
											<div class="recent-posts-date">September 9, 2022<span class="sep">/</span></div>
											<div class="recent-posts-comments"><a href="https://trendoceans.com/uncover-linux/#respond">0 Comments</a></div>
										</div>

									</div>

								</div>

							</li>

						
							<li class="clr">

																	<a href="https://trendoceans.com/subfinder-linux/" title="Subfinder: Fast Passive Subdomain Enumeration Tool in Linux" class="recent-posts-thumbnail">
										<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNTAiIGhlaWdodD0iMTUwIiB2aWV3Qm94PSIwIDAgMTUwIDE1MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="150" height="150" data-src="https://trendoceans.com/wp-content/uploads/2022/09/subfinder-1-150x150.webp" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Subfinder: Fast Passive Subdomain Enumeration Tool in Linux" itemprop="image" loading="lazy" data-srcset="https://trendoceans.com/wp-content/uploads/2022/09/subfinder-1-150x150.webp 150w, https://trendoceans.com/wp-content/uploads/2022/09/subfinder-1-600x600.webp 600w" data-sizes="(max-width: 150px) 100vw, 150px"/><noscript><img width="150" height="150" src="https://trendoceans.com/wp-content/uploads/2022/09/subfinder-1-150x150.webp" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Subfinder: Fast Passive Subdomain Enumeration Tool in Linux" itemprop="image" loading="lazy" srcset="https://trendoceans.com/wp-content/uploads/2022/09/subfinder-1-150x150.webp 150w, https://trendoceans.com/wp-content/uploads/2022/09/subfinder-1-600x600.webp 600w" sizes="(max-width: 150px) 100vw, 150px" /></noscript>
										<span class="overlay"></span>
									</a>
								
								<div class="recent-posts-details clr">

									<div class="recent-posts-details-inner clr">

										<a href="https://trendoceans.com/subfinder-linux/" class="recent-posts-title">Subfinder: Fast Passive Subdomain Enumeration Tool in Linux</a>

										<div class="recent-posts-info clr">
											<div class="recent-posts-date">September 8, 2022<span class="sep">/</span></div>
											<div class="recent-posts-comments"><a href="https://trendoceans.com/subfinder-linux/#respond">0 Comments</a></div>
										</div>

									</div>

								</div>

							</li>

						
							<li class="clr">

																	<a href="https://trendoceans.com/usbguard-usage-in-linux/" title="How to Allow, Block, and Reject USB Drives to Protect Your System from Malicious USB" class="recent-posts-thumbnail">
										<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNTAiIGhlaWdodD0iMTUwIiB2aWV3Qm94PSIwIDAgMTUwIDE1MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="150" height="150" data-src="https://trendoceans.com/wp-content/uploads/2022/09/stop-malicious-usb-drive-150x150.webp" class="attachment-thumbnail size-thumbnail wp-post-image" alt="How to Allow, Block, and Reject USB Drives to Protect Your System from Malicious USB" itemprop="image" loading="lazy" data-srcset="https://trendoceans.com/wp-content/uploads/2022/09/stop-malicious-usb-drive-150x150.webp 150w, https://trendoceans.com/wp-content/uploads/2022/09/stop-malicious-usb-drive-600x600.webp 600w" data-sizes="(max-width: 150px) 100vw, 150px"/><noscript><img width="150" height="150" src="https://trendoceans.com/wp-content/uploads/2022/09/stop-malicious-usb-drive-150x150.webp" class="attachment-thumbnail size-thumbnail wp-post-image" alt="How to Allow, Block, and Reject USB Drives to Protect Your System from Malicious USB" itemprop="image" loading="lazy" srcset="https://trendoceans.com/wp-content/uploads/2022/09/stop-malicious-usb-drive-150x150.webp 150w, https://trendoceans.com/wp-content/uploads/2022/09/stop-malicious-usb-drive-600x600.webp 600w" sizes="(max-width: 150px) 100vw, 150px" /></noscript>
										<span class="overlay"></span>
									</a>
								
								<div class="recent-posts-details clr">

									<div class="recent-posts-details-inner clr">

										<a href="https://trendoceans.com/usbguard-usage-in-linux/" class="recent-posts-title">How to Allow, Block, and Reject USB Drives to Protect Your System from Malicious USB</a>

										<div class="recent-posts-info clr">
											<div class="recent-posts-date">September 8, 2022<span class="sep">/</span></div>
											<div class="recent-posts-comments"><a href="https://trendoceans.com/usbguard-usage-in-linux/#respond">0 Comments</a></div>
										</div>

									</div>

								</div>

							</li>

						
							<li class="clr">

																	<a href="https://trendoceans.com/zellij-terminal-workspace/" title="Zellij: A Terminal Workspace to Super Charge Your Productivity" class="recent-posts-thumbnail">
										<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNTAiIGhlaWdodD0iMTUwIiB2aWV3Qm94PSIwIDAgMTUwIDE1MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="150" height="150" data-src="https://trendoceans.com/wp-content/uploads/2022/08/Zellij-terminal-150x150.webp" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Zellij: A Terminal Workspace to Super Charge Your Productivity" itemprop="image" loading="lazy" data-srcset="https://trendoceans.com/wp-content/uploads/2022/08/Zellij-terminal-150x150.webp 150w, https://trendoceans.com/wp-content/uploads/2022/08/Zellij-terminal-600x600.webp 600w" data-sizes="(max-width: 150px) 100vw, 150px"/><noscript><img width="150" height="150" src="https://trendoceans.com/wp-content/uploads/2022/08/Zellij-terminal-150x150.webp" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Zellij: A Terminal Workspace to Super Charge Your Productivity" itemprop="image" loading="lazy" srcset="https://trendoceans.com/wp-content/uploads/2022/08/Zellij-terminal-150x150.webp 150w, https://trendoceans.com/wp-content/uploads/2022/08/Zellij-terminal-600x600.webp 600w" sizes="(max-width: 150px) 100vw, 150px" /></noscript>
										<span class="overlay"></span>
									</a>
								
								<div class="recent-posts-details clr">

									<div class="recent-posts-details-inner clr">

										<a href="https://trendoceans.com/zellij-terminal-workspace/" class="recent-posts-title">Zellij: A Terminal Workspace to Super Charge Your Productivity</a>

										<div class="recent-posts-info clr">
											<div class="recent-posts-date">September 7, 2022<span class="sep">/</span></div>
											<div class="recent-posts-comments"><a href="https://trendoceans.com/zellij-terminal-workspace/#respond">0 Comments</a></div>
										</div>

									</div>

								</div>

							</li>

						
							<li class="clr">

																	<a href="https://trendoceans.com/gum-tool-linux/" title="Gum:  A Tool for Glamorous Shell Scripts in Linux" class="recent-posts-thumbnail">
										<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNTAiIGhlaWdodD0iMTUwIiB2aWV3Qm94PSIwIDAgMTUwIDE1MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="150" height="150" data-src="https://trendoceans.com/wp-content/uploads/2022/08/Install-gum-150x150.webp" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Gum:  A Tool for Glamorous Shell Scripts in Linux" itemprop="image" loading="lazy" data-srcset="https://trendoceans.com/wp-content/uploads/2022/08/Install-gum-150x150.webp 150w, https://trendoceans.com/wp-content/uploads/2022/08/Install-gum-600x600.webp 600w" data-sizes="(max-width: 150px) 100vw, 150px"/><noscript><img width="150" height="150" src="https://trendoceans.com/wp-content/uploads/2022/08/Install-gum-150x150.webp" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Gum:  A Tool for Glamorous Shell Scripts in Linux" itemprop="image" loading="lazy" srcset="https://trendoceans.com/wp-content/uploads/2022/08/Install-gum-150x150.webp 150w, https://trendoceans.com/wp-content/uploads/2022/08/Install-gum-600x600.webp 600w" sizes="(max-width: 150px) 100vw, 150px" /></noscript>
										<span class="overlay"></span>
									</a>
								
								<div class="recent-posts-details clr">

									<div class="recent-posts-details-inner clr">

										<a href="https://trendoceans.com/gum-tool-linux/" class="recent-posts-title">Gum:  A Tool for Glamorous Shell Scripts in Linux</a>

										<div class="recent-posts-info clr">
											<div class="recent-posts-date">September 7, 2022<span class="sep">/</span></div>
											<div class="recent-posts-comments"><a href="https://trendoceans.com/gum-tool-linux/#respond">0 Comments</a></div>
										</div>

									</div>

								</div>

							</li>

						
							<li class="clr">

																	<a href="https://trendoceans.com/tere-terminal-file-explorer/" title="Tere: A Faster Alternative to cd + ls in Linux" class="recent-posts-thumbnail">
										<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNTAiIGhlaWdodD0iMTUwIiB2aWV3Qm94PSIwIDAgMTUwIDE1MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="150" height="150" data-src="https://trendoceans.com/wp-content/uploads/2022/08/tere-file-manager-150x150.webp" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Tere: A Faster Alternative to cd + ls in Linux" itemprop="image" loading="lazy" data-srcset="https://trendoceans.com/wp-content/uploads/2022/08/tere-file-manager-150x150.webp 150w, https://trendoceans.com/wp-content/uploads/2022/08/tere-file-manager-600x600.webp 600w" data-sizes="(max-width: 150px) 100vw, 150px"/><noscript><img width="150" height="150" src="https://trendoceans.com/wp-content/uploads/2022/08/tere-file-manager-150x150.webp" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Tere: A Faster Alternative to cd + ls in Linux" itemprop="image" loading="lazy" srcset="https://trendoceans.com/wp-content/uploads/2022/08/tere-file-manager-150x150.webp 150w, https://trendoceans.com/wp-content/uploads/2022/08/tere-file-manager-600x600.webp 600w" sizes="(max-width: 150px) 100vw, 150px" /></noscript>
										<span class="overlay"></span>
									</a>
								
								<div class="recent-posts-details clr">

									<div class="recent-posts-details-inner clr">

										<a href="https://trendoceans.com/tere-terminal-file-explorer/" class="recent-posts-title">Tere: A Faster Alternative to cd + ls in Linux</a>

										<div class="recent-posts-info clr">
											<div class="recent-posts-date">September 6, 2022<span class="sep">/</span></div>
											<div class="recent-posts-comments"><a href="https://trendoceans.com/tere-terminal-file-explorer/#respond">0 Comments</a></div>
										</div>

									</div>

								</div>

							</li>

						
							<li class="clr">

																	<a href="https://trendoceans.com/nnn-linux-terminal-file-manager/" title="nnn: A Linux Terminal File Manager To Reduce Your Terminal Navigational Stress" class="recent-posts-thumbnail">
										<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNTAiIGhlaWdodD0iMTUwIiB2aWV3Qm94PSIwIDAgMTUwIDE1MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="150" height="150" data-src="https://trendoceans.com/wp-content/uploads/2022/08/nnn-file-manager-150x150.webp" class="attachment-thumbnail size-thumbnail wp-post-image" alt="nnn: A Linux Terminal File Manager To Reduce Your Terminal Navigational Stress" itemprop="image" loading="lazy" data-srcset="https://trendoceans.com/wp-content/uploads/2022/08/nnn-file-manager-150x150.webp 150w, https://trendoceans.com/wp-content/uploads/2022/08/nnn-file-manager-600x600.webp 600w" data-sizes="(max-width: 150px) 100vw, 150px"/><noscript><img width="150" height="150" src="https://trendoceans.com/wp-content/uploads/2022/08/nnn-file-manager-150x150.webp" class="attachment-thumbnail size-thumbnail wp-post-image" alt="nnn: A Linux Terminal File Manager To Reduce Your Terminal Navigational Stress" itemprop="image" loading="lazy" srcset="https://trendoceans.com/wp-content/uploads/2022/08/nnn-file-manager-150x150.webp 150w, https://trendoceans.com/wp-content/uploads/2022/08/nnn-file-manager-600x600.webp 600w" sizes="(max-width: 150px) 100vw, 150px" /></noscript>
										<span class="overlay"></span>
									</a>
								
								<div class="recent-posts-details clr">

									<div class="recent-posts-details-inner clr">

										<a href="https://trendoceans.com/nnn-linux-terminal-file-manager/" class="recent-posts-title">nnn: A Linux Terminal File Manager To Reduce Your Terminal Navigational Stress</a>

										<div class="recent-posts-info clr">
											<div class="recent-posts-date">September 6, 2022<span class="sep">/</span></div>
											<div class="recent-posts-comments"><a href="https://trendoceans.com/nnn-linux-terminal-file-manager/#respond">0 Comments</a></div>
										</div>

									</div>

								</div>

							</li>

						
							<li class="clr">

																	<a href="https://trendoceans.com/atuin-linux/" title="Atuin: A Powerful Alternative for Shell History (SQLite Database) in Linux" class="recent-posts-thumbnail">
										<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNTAiIGhlaWdodD0iMTUwIiB2aWV3Qm94PSIwIDAgMTUwIDE1MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2NmZDRkYiIvPjwvc3ZnPg==" width="150" height="150" data-src="https://trendoceans.com/wp-content/uploads/2022/09/Autin-150x150.webp" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Atuin: A Powerful Alternative for Shell History (SQLite Database) in Linux" itemprop="image" loading="lazy" data-srcset="https://trendoceans.com/wp-content/uploads/2022/09/Autin-150x150.webp 150w, https://trendoceans.com/wp-content/uploads/2022/09/Autin-600x600.webp 600w" data-sizes="(max-width: 150px) 100vw, 150px"/><noscript><img width="150" height="150" src="https://trendoceans.com/wp-content/uploads/2022/09/Autin-150x150.webp" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Atuin: A Powerful Alternative for Shell History (SQLite Database) in Linux" itemprop="image" loading="lazy" srcset="https://trendoceans.com/wp-content/uploads/2022/09/Autin-150x150.webp 150w, https://trendoceans.com/wp-content/uploads/2022/09/Autin-600x600.webp 600w" sizes="(max-width: 150px) 100vw, 150px" /></noscript>
										<span class="overlay"></span>
									</a>
								
								<div class="recent-posts-details clr">

									<div class="recent-posts-details-inner clr">

										<a href="https://trendoceans.com/atuin-linux/" class="recent-posts-title">Atuin: A Powerful Alternative for Shell History (SQLite Database) in Linux</a>

										<div class="recent-posts-info clr">
											<div class="recent-posts-date">September 5, 2022<span class="sep">/</span></div>
											<div class="recent-posts-comments"><a href="https://trendoceans.com/atuin-linux/#respond">0 Comments</a></div>
										</div>

									</div>

								</div>

							</li>

						
					
				</ul>

				
			</div><div id="block-2" class="sidebar-box widget_block clr"><script src="https://storage.ko-fi.com/cdn/scripts/overlay-widget.js"></script>
<script>
  kofiWidgetOverlay.draw('trendoceans', {
    'type': 'floating-chat',
    'floating-chat.donateButton.text': 'Tip Me',
    'floating-chat.donateButton.background-color': '#794bc4',
    'floating-chat.donateButton.text-color': '#fff'
  });
</script></div>
	</div><!-- #sidebar-inner -->

	
</aside><!-- #right-sidebar -->


	</div><!-- #content-wrap -->

	

	</main><!-- #main -->

	
	
	
		
<footer id="footer" class="site-footer" itemscope="itemscope" itemtype="https://schema.org/WPFooter" role="contentinfo">

	
	<div id="footer-inner" class="clr">

		

<div id="footer-bottom" class="clr">

	
	<div id="footer-bottom-inner" class="container clr">

		
			<div id="footer-bottom-menu" class="navigation clr">

				<div class="menu-social-container"><ul id="menu-social-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72"><a href="https://www.facebook.com/trendoceans">Facebook</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-73"><a href="https://www.instagram.com/trendoceans/">Instagram</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-74"><a href="https://twitter.com/trendoceans">Twitter</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2739"><a href="https://t.me/trendoceans">Telegram</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1667"><a href="https://www.youtube.com/channel/UClRBOuS5x9PT8D6BpYaWO-A">Youtube</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-94"><a href="/cdn-cgi/l/email-protection#16757978627775625662647378727975737778653875797b">E-mail</a></li>
</ul></div>
			</div><!-- #footer-bottom-menu -->

			
		
			<div id="copyright" class="clr" role="contentinfo">
				TREND OCEANS © 2022. All Rights Reserved.			</div><!-- #copyright -->

			
	</div><!-- #footer-bottom-inner -->

	
</div><!-- #footer-bottom -->


	</div><!-- #footer-inner -->

	
</footer><!-- #footer -->

	
	
</div><!-- #wrap -->


</div><!-- #outer-wrap -->






<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script id="convertkit-broadcasts-js-extra">
var convertkit_broadcasts = {"ajax_url":"https:\/\/trendoceans.com\/wp-admin\/admin-ajax.php","action":"convertkit_broadcasts_render","debug":""};
</script>
<script src="https://trendoceans.com/wp-content/plugins/convertkit/resources/frontend/js/broadcasts.js?ver=1.9.8.4" id="convertkit-broadcasts-js"></script>
<script src="https://trendoceans.com/wp-content/plugins/contact-form-7/includes/swv/js/index.js?ver=5.6.3" id="swv-js"></script>
<script id="contact-form-7-js-extra">
var wpcf7 = {"api":{"root":"https:\/\/trendoceans.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
</script>
<script src="https://trendoceans.com/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.6.3" id="contact-form-7-js"></script>
<script id="convertkit-js-js-extra">
var convertkit = {"ajaxurl":"https:\/\/trendoceans.com\/wp-admin\/admin-ajax.php","debug":"","nonce":"2142d73364","subscriber_id":"0","tag":"","post_id":"27982"};
</script>
<script src="https://trendoceans.com/wp-content/plugins/convertkit/resources/frontend/js/convertkit.js?ver=1.9.8.4" id="convertkit-js-js"></script>
<script src="https://trendoceans.com/wp-includes/js/comment-reply.min.js?ver=6.0.2" id="comment-reply-js"></script>
<script src="https://trendoceans.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4" id="imagesloaded-js"></script>
<script id="oceanwp-main-js-extra">
var oceanwpLocalize = {"nonce":"0d7d573482","isRTL":"","menuSearchStyle":"disabled","mobileMenuSearchStyle":"disabled","sidrSource":null,"sidrDisplace":"1","sidrSide":"left","sidrDropdownTarget":"link","verticalHeaderTarget":"link","customSelects":".woocommerce-ordering .orderby, #dropdown_product_cat, .widget_categories select, .widget_archive select, .single-product .variations_form .variations select","ajax_url":"https:\/\/trendoceans.com\/wp-admin\/admin-ajax.php"};
</script>
<script src="https://trendoceans.com/wp-content/themes/oceanwp/assets/js/theme.min.js?ver=1.0" id="oceanwp-main-js"></script>
<script src="https://trendoceans.com/wp-content/themes/oceanwp/assets/js/drop-down-mobile-menu.min.js?ver=1.0" id="oceanwp-drop-down-mobile-menu-js"></script>
<script src="https://trendoceans.com/wp-content/themes/oceanwp/assets/js/equal-height-elements.min.js?ver=1.0" id="oceanwp-equal-height-elements-js"></script>
<script src="https://trendoceans.com/wp-content/themes/oceanwp/assets/js/vendors/flickity.pkgd.min.js?ver=1.0" id="ow-flickity-js"></script>
<script src="https://trendoceans.com/wp-content/themes/oceanwp/assets/js/ow-slider.min.js?ver=1.0" id="oceanwp-slider-js"></script>
<script src="https://trendoceans.com/wp-content/themes/oceanwp/assets/js/scroll-effect.min.js?ver=1.0" id="oceanwp-scroll-effect-js"></script>
<script src="https://trendoceans.com/wp-content/themes/oceanwp/assets/js/select.min.js?ver=1.0" id="oceanwp-select-js"></script>
<script src="https://trendoceans.com/wp-content/themes/oceanwp/assets/js/ow-infinite-scroll.min.js?ver=1.0" id="oceanwp-infinite-scroll-js"></script>
<script src="https://trendoceans.com/wp-content/plugins/litespeed-cache/assets/js/instant_click.min.js?ver=5.2.1" id="litespeed-cache-js"></script>
<script src="https://trendoceans.com/wp-content/plugins/wp-featherlight/js/wpFeatherlight.pkgd.min.js?ver=1.3.4" id="wp-featherlight-js"></script>
<script src="https://trendoceans.com/wp-content/plugins/ocean-social-sharing/assets/js/social.js?ver=2.0.2" id="oss-social-share-script-js"></script>
<script src="https://trendoceans.com/wp-content/plugins/easy-table-of-contents/vendor/smooth-scroll/jquery.smooth-scroll.min.js?ver=2.2.0" id="ez-toc-jquery-smooth-scroll-js"></script>
<script src="https://trendoceans.com/wp-content/plugins/easy-table-of-contents/vendor/js-cookie/js.cookie.min.js?ver=2.2.1" id="ez-toc-js-cookie-js"></script>
<script src="https://trendoceans.com/wp-content/plugins/easy-table-of-contents/vendor/sticky-kit/jquery.sticky-kit.min.js?ver=1.9.2" id="ez-toc-jquery-sticky-kit-js"></script>
<script id="ez-toc-js-js-extra">
var ezTOC = {"smooth_scroll":"1","scroll_offset":"30"};
</script>
<script src="https://trendoceans.com/wp-content/plugins/easy-table-of-contents/assets/js/front.min.js?ver=2.0.33.2-1662710694" id="ez-toc-js-js"></script>
<script data-no-optimize="1" defer="">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</script>


<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=0&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script>
<script type="text/javascript" data-cfasync="false"></script>
<script>var _audins_dom="trendoceans_com",_audins_did=314194;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.trendoceans_com,DomainId.314194" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script>__ez.queue.addFile('/beardeddragon/drake.js', '/beardeddragon/drake.js?gcb=0&cb=4', false, [], true, false, true, false);</script><script>(function(){var js = "window['__CF$cv$params']={r:'748345393dd15cfb',m:'TQaYK3FCRxQxzh2Gp.iLvkkxKTUo6Ya4l9QJKm2LQi8-1662761599-0-AU+GsukeASUDhOZT8UJPdC/zoTrayPsIVPKg6q0p7hwBxL/g0hE8XySEdRB86+Kn2v3h+JdWSpJieHaKGbBeQhQqdC4aho9+2XpxA4lw7A1IqCmMN3lQKCKYq2OGgjQl2w==',s:[0x7811722aad,0x6efd74fd82],u:'/cdn-cgi/challenge-platform/h/g'};var now=Date.now()/1000,offset=14400,ts=''+(Math.floor(now)-Math.floor(now%offset)),_cpo=document.createElement('script');_cpo.nonce='',_cpo.src='/cdn-cgi/challenge-platform/h/g/scripts/alpha/invisible.js?ts='+ts,document.getElementsByTagName('head')[0].appendChild(_cpo);";var _0xh = document.createElement('iframe');_0xh.height = 1;_0xh.width = 1;_0xh.style.position = 'absolute';_0xh.style.top = 0;_0xh.style.left = 0;_0xh.style.border = 'none';_0xh.style.visibility = 'hidden';document.body.appendChild(_0xh);function handler() {var _0xi = _0xh.contentDocument || _0xh.contentWindow.document;if (_0xi) {var _0xj = _0xi.createElement('script');_0xj.nonce = '';_0xj.innerHTML = js;_0xi.getElementsByTagName('head')[0].appendChild(_0xj);}}if (document.readyState !== 'loading') {handler();} else if (window.addEventListener) {document.addEventListener('DOMContentLoaded', handler);} else {var prev = document.onreadystatechange || function () {};document.onreadystatechange = function (e) {prev(e);if (document.readyState !== 'loading') {document.onreadystatechange = prev;handler();}};}})();</script></body></html><!-- Page generated by LiteSpeed Cache 5.2.1 on 2022-09-09 10:49:45 -->